Oct 202010
 

Well, my Ubuntu Server box running Lio-Target is still running great, and performing perfectly under the continous stress testing I’ve done.

While I’m waiting for a few more days of the stress test to finish, I’m setting up my old Soekris Net4801.

I’m install Ubuntu Server 10.04 TLS on to the Soekris Net4801 via remote PXE netboot. Afterwards I’m going to compile Lio-target 3.4 (kernel 2.6.34) on the device and test out performance of the iSCSI target. It won’t be anything special since the net4801 is so slow, but it’ll be interesting to see for sure.

I’ll also be sticking in a PCI – USB2.0 card inside of the net4801 to get USB2.0 speeds on a removal drive.

After this little experiment I might rip out the cross compiler and build Lio-Target on a Linksys WRT610N if I can to check out the performance on that. I know these little devices have quite a bit of power, gigabit networking, and a single USB 2.0 port built right in!

As promised I’ll be posting more detailed posts in the future once all the fun is done!

  8 Responses to “Plans to install Lio-target on a Soekris Net4801”

  1. Stephen, this is the first blog I have encountered which deals with a lio target kernel install – thank you.
    I find the lio and risingtide websites quite onerous to navigate and have yet to see how to install a custom lio kernel detailed as explicitely as on your blog.

    I have been looking to do this for ages on Ubuntu 10.04TLS – but have only had the courage to try the lio backports.

    Can you possibly give a brief outline on how you compiled the new kernel for Ubuntu 10.04TLS – I’m very keen to try the latest ver 4.0 (I’m stuck on backports 3.1.4 – which is causing issues with my 2.6.32 kernel).

    Kind regards,

    Bob

  2. Hi Bob,

    Check out:
    http://www.stephenwagner.com/?p=242

    It’s my blog post to get Lio-Target up and running by compiling a kernel. It should apply to you. Keep in mind that was Lio 3.4, but it’s the exact same for building Lio 4.0, you just need to use git to grab the 4.0rc.

    Keep in mind that for some reason the blog post cut off some syntax on the actual commands to configure/use Lio, but sounds like you already know how to use it, and your just wanting to try the newer version so it should work for you.

    Let me know if you have any particular questions.

    Stephen

  3. Thanks Stephen,

    I have just looked and seen the latest lio release has been merged (I believe) into the latest 2.6.37 upstream release candidate….

    So will be trying this kernel.

    On the Ubuntu front – I seem to be suffering from the page allocation failure bug under heavy target loads – is this something you have seen at all on your Ubuntu install (http://web.archiveorange.com/archive/v/LLXmLeKLNXwv2piKAfyn)?

    Bob

  4. Hi Bob,

    Yes, it’s getting merged. Found that out after speaking with one of the developers at RisingTide. I’m stoked for it, and I’ll be even more stoked when CentOS gets up to that kernel release in their updates.

    As for the page allocation failure… Are you running your iSCSI target server as a VM? Or this issue is happening to VMs your running that are hosting on a iSCSI volume?

    I haven’t run in to any issues whatsoever. I’m running Ubuntu and Lio naively on a HP DL360 G5 server. I have 3 other servers running VMWare ESXi (HP ML350 G5, HP DL360 G5), and their datastores are being hosted on the iSCSI volumes. I’ve had absolutely no issues, even under EXTREME load.

  5. Wow….
    I’ve got two esx 4 hosts (12 VMs in total – so not a huge number – with both hosts having 32gb mem and quad core amds)- one running directly off an 8 bay qnap (iscsi) the other off a 15 bay ubuntu server (iscsi) -again direct -full gbit cisco backbone. All VMs are on the native esx4 hosts.
    I get continual fabric disconnects and then the allocation failures on the 10.04 server (under heavy loads); which causes my VMs to hang – not ideal!

    I started with a centos build – but ran into issues similar to yours – so I switched to 10.04 TLS. I feel commited to it now (after struggling with vlans and iscsi)!!

    So – will we be able to download the new 2.6.37 kernel and use the LIO target natively without compiling anything (i.e. lio-utils etc….)?
    I spoke with Mr Nicholas Bellinger a while ago about buffered fileio support on the backports – he was extremely helpful.

    Bob

  6. Stephen,

    can I ask what network config you have on the 10.04 LTS box?
    I seem to be getting a considerable number of dropouts on a Mode 4 Bonded interface running VLANS (this is the root cause my stability issues!).

    I only get these issues when the bond is hammered (as in the case of supporting an LIO Target) – not during “normal” network activity.

    I’m going to try a mode 4 bonded interface without VLAN support to see if this has any impact.

    Have you encountered any such problems using ifenslaves, vlan or similar?

    Kind regards,

    Bob

  7. Hi Bob,

    Sorry for the late reply. Actually, I havn’t done any testing yet with lio on both trunked NICs, or VLANs. Everything I’ve done has just been over a simple single NIC.

    What exactly has been happening? Is it erroring out? Just for the hell of it, have you tried removing the trunk and testing with just one NIC instead of trunked NICs?

    Also, would it be worth while setting up a test lio box, and trying different hardware? What are you currently running lio on?

    Stephen

  8. Hi Stephen,
    I’ve got quite a high spec machine – so think my issues lay elsewhere (2 quad AMDs – 9690 BBU 16 way raid card – quad Intel 1Gb NICs – 8Gb ram etc…). I am getting page allocation failures under high network load (both on the LIO and non LIO targets) and have seen some issues related to this (http://kerneltrap.org/mailarchive/linux-kernel/2010/8/24/4610529/thread#mid-4610529) so have decided to upgrade my Kernel (with LIO support!) to 2.6.37 to see if this helps.

    I’m running vlans over a mode 4 bond with an MTU of 9000 – which I think is causing tcp packet allocation errors under heavy load – I’ve tried different network cards (onboard and plugin) to no avail….

    I’m guessing because you are using a LIO kernel you are on version > 2.6.32 – which *maybe* why you haven’t seen this condition (I’m running the LIO backport).

    I’ll upgrade and report back

    Bob

 Leave a Reply

Connect with Facebook

(required)

(required)

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>